Firefox 3.5 Preview Released, Breaks WordPress Admin Interface

Mozilla released Firefox 3.5 Preview, also known as Firefox 3.5b99, a couple days ago as a sneak peak at the upcoming release candidate. If you are running Beta 4, you can get it by checking for updates.

While most things seem to work just fine, the WordPress admin interface has somehow been broken by this new release, at least for version 2.7.x. It is still somewhat usable, but AJAX and other JavaScript related features seem to not work. Of course, the admin interface is heavy with such features, rendering many tasks very difficult.

If you are a Firefox user, you may want to hold off on upgrading to 3.5 Preview if you run WordPress sites. Or, this might be a great time to try out other browsers like Chrome or Opera for a while.

UPDATE 2009/06/11: WordPress 2.8 was released yesterday and this new version works well with Firefox 3.5 Preview. It also provides a lot of snazzy cool new features. Check it out if you can upgrade.

One thought on “Firefox 3.5 Preview Released, Breaks WordPress Admin Interface

Leave a Reply

Your email address will not be published. Required fields are marked *